Apple suggests updating all iOS devices to a newer software version due to a processor flaw

Yesterday TechJuice reported about a bug in processors powered by Intel and used by many tech giants including Apple, which made contents of the protected kernel memory vulnerable. For now, Apple has said that if all the iOS devices including iPads, iMacs, and iPhones, will be updated to the newer version of iOS, they will remain protected from one of the vulnerabilities the bug has caused in the ARM or Intel processors.

On Thursday, Apple admitted that all of its Macs, iPhones, and iPads could be affected by the two newly discovered flaws regarding Intel-powered processors, named Meltdown and Spectre. Meltdown and Spectre affected the processors of all big giants including the likes of ARM and Intel. The company also mentioned an exception for Apple Watch which only got affected Spectre. The security flaw not even spared Apple TVs. However, an Apple’s spokesperson clarified in a statement that these vulnerabilities are not much harmful and widespread. According to the statement,

“There are no known exploits impacting customers at this time.”

Furthermore, Apple depicts that the flaws are even difficult for hackers to exploit as the bug affects Macs or other iOS devices only if there is a malicious app loaded on the device. Apple is suggesting its users that they must update their iOS devices to the latest software version, which was released back in December, to stay protected from the bug. In addition tech giant has also recommended its users to download software from trusted locations such as App Store to avoid software with malware.

Meanwhile, another report from ArsTechnica which reveals the progress going on Intel’s end claims that Intel’s chief sold all the stock of affected processors even after acknowledgment of security flaws.

Leave a Reply

Your email address will not be published. Required fields are marked *